$re = '/[^|]+$/i';
$str = 'String 1 | string 2 | string 3';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);