import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(a)[^>]*?(?!match)[^>]+>[^<]+<\\/\\1>";
final String string = "текст 1\n"
+ "<a class=\"btn\" href=\"https://site.ru/\">Ссылка1</a>\n"
+ "текст 2\n"
+ "<a class=\"btn\" href=\"https://match.com\">Ссылка2</a>\n"
+ "текст 3\n"
+ "<a class=\"btn\" href=\"https://fall.com/\">Ссылка3</a>\n"
+ "текст 4";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}