#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?:(?=([\s\S]+?(?=\nX:|$)))\1){2}"
Local $sString = "T:Broken Pledge, The R:reel D:De Dannan: Selected Reels and Jigs. Z:Also played in Edor, see #734 Z:id:hn-reel-56 M:C| K:Ddor dcAG ADDB|cAGF ECCE|D2 (3EFG Addc|AcGc Aefe| dcAG FGAB|c2Bd cAGE|D2 (3EFG AddB|cAGE FDD2:| |:dcAG Acde|~f3d ecAB|cAGE GAcd|ec~c2 eage| dcAG Acde|fedf ecAG|~F3G AddB|cAGE FDD2:| P:"Variations:" |:dcAG ~A3B|cAGF ECCE|DEFG Addc|(3ABc Gc Aefe| dcAG FGAB|c2Bd cAGE|DEFG AddB|A2GE FDD2:| |:dcAG Acde|~f3d ecAB|cAGE GAcd|ec~c2 eage| dcAG Acde|~f3d ecAG|FEFG AddB|A2GE FDD2:| " & @CRLF & _
"X:2 T:Broken Pledge, The M:C L:1/8 Q:250 K:D dcAG A2 dB | cAGF EDC2 | DEFG Ad ~d2 | AcGc Adfe | dcAG A2 dB | cAGF EDC2 | DEFG Ad ~d2 | AcGc ADD2 :| |: dcAG A2 de | fedf edAB | cAGE GAcd | ec ~c2 eage | dcAG A2 de | fedf edcA | F3 E FGAB | cAGE {F}ED D2 :|| 2021-09-17T18:55:34.779Z c2977fd7-2057-44cc-bdf3-7f4243a53e33" & @CRLF & _
"X:2 T:Broken Pledge, The M:C L:1/8 Q:250 K:D dcAG A2 dB | cAGF EDC2 | DEFG Ad ~d2 | AcGc Adfe | dcAG A2 dB | cAGF EDC2 | DEFG Ad ~d2 | AcGc ADD2 :| |: dcAG A2 de | fedf edAB | cAGE GAcd | ec ~c2 eage | dcAG A2 de | fedf edcA | F3 E FGAB | cAGE {F}ED D2 :|| 2021-09-17T18:55:34.779Z c2977fd7-2057-44cc-bdf3-7f4243a53e33 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")