re = /@\w+/
str = '@login привет @loginSecond привет @loginSecond123123123 привет'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end