re = /\b((?i)propercase(?-i)\b(?<!ProperCase))/
str = 'propercase
ProPercase
PROPERCASE
proPercase
ProperCase'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end