#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?<name>\w+)\s*\(\K(?<e>[^()]*(?:\((?&e)\)[^()]*)*)(?=\))"
Local $sString = "foo(() ((hello) world))" & @CRLF & _
"bar (hello world!)" & @CRLF & _
"baz(ddd(()))" & @CRLF & _
"" & @CRLF & _
"bazbaz(dsadsa")" dsada)" & @CRLF & _
"bazbaz(dsadsa")" d(()(das))das)das)ds)a(d(sa(d)()()sada); ;; d(ssss)" & @CRLF & _
"" & @CRLF & _
"h(dsaqwd)" & @CRLF & _
"h(dsaqwd);h(dsaqwd)" & @CRLF & _
"h(dsaqwd); h(dsaqwd);" & @CRLF & _
"" & @CRLF & _
"foo(() ((hello) world)); bar(gffjdk)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")