using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(?P<timestamp>\d+-\d{2}-\d{2} \d{2}:\d{2}:\d{2},\d{3})\] (?P<level>[A-Z]+) \[(?P<context>.+?)\] (?P<msg>.+) \((?P<logger>.+)\)";
string input = @"[2023-10-24 20:33:14,925] DEBUG [Controller id=2] Topics not in preferred replica for broker 2 Map() (kafka.controller.KafkaController)
[2023-10-25 00:30:13,095] INFO [RaftManager nodeId=1] Disconnecting from node 2 due to request timeout. (org.apache.kafka.clients.NetworkClient)
[2023-10-25 00:01:39,422] INFO [RaftManager nodeId=1] Disconnecting from node 2 due to request timeout. (org.apache.kafka.clients.NetworkClient)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}