import Foundation
let pattern = #"\[(?P<timestamp>\d+-\d{2}-\d{2} \d{2}:\d{2}:\d{2},\d{3})\] (?P<level>[A-Z]+) \[(?P<context>.+?)\] (?P<msg>.+) \((?P<logger>.+)\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[2023-10-24 20:33:14,925] DEBUG [Controller id=2] Topics not in preferred replica for broker 2 Map() (kafka.controller.KafkaController)
[2023-10-25 00:30:13,095] INFO [RaftManager nodeId=1] Disconnecting from node 2 due to request timeout. (org.apache.kafka.clients.NetworkClient)
[2023-10-25 00:01:39,422] INFO [RaftManager nodeId=1] Disconnecting from node 2 due to request timeout. (org.apache.kafka.clients.NetworkClient)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)