import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bif\\b\\s*\\(([\\w\\%\\$\\.]+\\s*[\\=\\!\\<\\>].*[\\&\\|]?)?\\)";
final String string = "if(%CDOCCM=\" A\")\n"
+ "if(CampoModif())\n"
+ "if(%MCRVINC=0\")\n"
+ "if($SCR_P_U.CHAR3!=\"P\")\n"
+ "if(%AUX1!=%ITPRED || %AUX2!=%MMOVIM)\n"
+ "if(%CBALCAO!=\"\" && %NUMCONTA!=\"\")\n"
+ "Limpar(%CCLIFUT)\n"
+ "Mandatorio(%CCLIFUT)\n"
+ "if(%CCLIFUT=\"\")\n"
+ "if(%ZCLIENTE=0)\n"
+ "if (%FM7 != 0)\n"
+ "if($TRANS_ENCADEOU_U=\"TV19\" && $cPRIMEIRAVOLTA_U=1)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}