re = /.*\\[\d\w]+ (?<InvoiceID>\d+)[ ]*(?<ExtraInfo>.*)\.(?<Ext>.*)$/m
str = 'I:\\ARInvoices\\COMPANY1\\Unused 39458 ExtraInfo.pdf
I:\\ARInvoices\\COMPANY1\\Unused 39458.pdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end