using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S|^)\n(?!\n)";
string substitution = @"$1[replacement]";
string input = @"
this is a
this is b
this is c
d
test
test
test
test
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}