#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((Q|Question|Problem:?|Example|EXAMPLE)\.? ?\d+\.? ?|(Question|Problem:?|Example|EXAMPLE) ?)"
Local $sString = "Q 12. This is question 1" & @CRLF & _
"" & @CRLF & _
"Example 1 This is question 2 Q.1" & @CRLF & _
"" & @CRLF & _
"Example This is question 3" & @CRLF & _
"" & @CRLF & _
"EXAMPLE 2 This is question 4 2.3" & @CRLF & _
"" & @CRLF & _
"Q.12. This is question 5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")