import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\/(.*)\\/([a-z]*)|.*)$";
final String string = "/^[0-9]+$/\n"
+ "/^(true|false)$/i\n"
+ "/^\\\\d{4}-\\\\d{2}-\\\\d{2}$/\n"
+ "/^\\\\d{4}-\\\\d{2}-\\\\d{2}T\\\\d{2}:\\\\d{2}$/i\n"
+ "yyyy-mm-ddThh:mm";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}