package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:\+91|0)\d{10}|[1-9]\d{9})$`)
var str = `+911234567891
01234567891
1234567891
0123456789`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}