$re = '/^(?:(?:\+91|0)\d{10}|[1-9]\d{9})$/m';
$str = '+911234567891
01234567891
1234567891
0123456789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);