package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(((http|https):\/\/)?www\.)?yuque\.com\/([a-zA-Z\=]*)\/([a-zA-Z]*)\/([a-zA-Z]*)\/?`)
var str = `https://www.yuque.com/cheche=xsrvr/sbzuyb/ygzghc/
https://www.yuque.com/cheche=xsrvr/sbzuyb/ygzghc
http://www.yuque.com/cheche=xsrvr/sbzuyb/ygzghc
www.yuque.com/cheche=xsrvr/sbzuyb/ygzghc
yuque.com/cheche=xsrvr/sbzuyb/ygzghc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}