$re = '/(((http|https):\/\/)?www\.)?yuque\.com\/([a-zA-Z\=]*)\/([a-zA-Z]*)\/([a-zA-Z]*)\/?/m';
$str = 'https://www.yuque.com/cheche=xsrvr/sbzuyb/ygzghc/
https://www.yuque.com/cheche=xsrvr/sbzuyb/ygzghc
http://www.yuque.com/cheche=xsrvr/sbzuyb/ygzghc
www.yuque.com/cheche=xsrvr/sbzuyb/ygzghc
yuque.com/cheche=xsrvr/sbzuyb/ygzghc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);