using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""accessRights"":\s*""[0-9,a-f,A-F]{5}""";
string substitution = @"""accessRights"":""abcde""";
string input = @"{
""users"": {
""accessRights"":""FFFFF"",
""name"": ""admin""
}
}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}