package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"accessRights":\s*"[0-9,a-f,A-F]{5}"`)
var str = `{
"users": {
"accessRights":"FFFFF",
"name": "admin"
}
}`
var substitution = ""accessRights":"abcde""
fmt.Println(re.ReplaceAllString(str, substitution))
}