import Foundation
let pattern = #""accessRights":\s*"[0-9,a-f,A-F]{5}""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{
"users": {
"accessRights":"FFFFF",
"name": "admin"
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""accessRights":"abcde""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)