package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)`{3}(`*[^`\n]+`*)`{3}`)
var str = `\`\`\`test\`\`\``
var substitution = "<pre>$1</pre>"
fmt.Println(re.ReplaceAllString(str, substitution))
}