import Foundation
let pattern = #"^\d{4}[a-zA-Z0-9]$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
# CPT is a uniform coding system consisting of descriptive terms and identifying codes used primarily to identify medical services and procedures furnished by physicians and other health care professionals for which they bill public or private health insurance programs.
# It is a numeric coding system maintained by the American Medical Association (AMA).
# CPT codes can be subdivided into 3 levels/categories (not to be confused with HCPCS Level II!):
# - Category I: Evaluation & Management Services, Anesthesia, Surgery, Radiology, Procedures, Pathology & Laboratory Procedures, and Medicine Services & Procedures. All 5 characters are numeric.
# - Category II: Optional, but provide extra information about additional procedures typically performed with Category I CPT Codes, for example 3008F is “Body Mass Index (BMI) documented” which occurs during the Evaluation & Management Services. First 4 digits numeric, followed by an “F”.
# - Category III: Describe emergent or experimental services that help providers and government agencies track efficacy of those medical techniques. They may become Category I but have an expiration of 5 years. First 4 digits are numeric, followed by any other letter.
# This regex does *not* match codes with optional modifiers:-
# "A medical coding modifier is two characters (letters or numbers) appended to a CPT® or HCPCS Level II code. The modifier provides additional information about the medical procedure, service, or supply involved without changing the meaning of the code. Medical coders use modifiers to tell the story of a particular encounter."
# (https://www.aapc.com/resources/what-are-medical-coding-modifiers)
# There is another pattern in regex101 that *does* match codes with optional modifiers
# Matched patterns (codes might not necessarily be genuine, in-dictionary codes! Regex simply matches the pattern)
33275
47360
3008F
0503F
1030F
6015F
0123T
0123t
# Does not match
0000
1
123456
123A
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)