using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"SITE ""(?=([^""]+))";
string input = @"SITE ""test_website--production"" (id:1207042133,bindings:http/127.0.0.1:9900:,state:Started)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}