import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(00\\d{3})\\s([\\d,-]+)";
final String string = "Desarrollo (N) 00103 27456,04\n"
+ "Concesiones (N) 00104\n"
+ "Patentes, licencias, marcas y similares (N) 00105\n"
+ "Fondo de comercio (N, A, P) 00106 1325,03\n"
+ "Aplicaciones informáticas (N) 00107 8757,92\n"
+ "Investigación (N) 00108\n"
+ "Propiedad intelectual (N) 00700\n"
+ "Otro inmovilizado intangible (N) 00109 -5643,01\n"
+ "Resto (A, P) 00110";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}