import Foundation
let pattern = #"(a\d+|A\d+|scl[^:]+):([^\']+)(\'|_)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
text curl -u scl_test_mon:ypB7HuW9u5yB'_'https://mycompany.com/api/healthcheck'?_2>&1
text curl -u a12345:ypB7HuW9u5yB'_'https://mycompany.com/api/healthcheck'?_2>&1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1:xxxxx\3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)