package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`'(.*?)'\B`)
var str = `'Cote d'Ivoire'
'United States'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}