package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^(generate|create|draw|make) (me|an?|the|this|that)? .* (at|in|on|of|for|about|showing|depicting|illustrating)`)
var str = `Generate an epic image of a dragon in flight
Create a realistic render of a futuristic city
Generate the perfect logo for a tech startup
Create this concept art for a fantasy novel
Generate that illustration about ancient myths
Create an animation showing a volcanic eruption
Generate a portrait depicting a medieval knight
Draw me a dragon on fire
Type your prompt below!
As long as the first parts of it are highlighted in multiple colors, like the examples above, the script will recognize your prompt and generate an image.
Type here...
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}