use strict;
my $str = 'Generate an epic image of a dragon in flight
Create a realistic render of a futuristic city
Generate the perfect logo for a tech startup
Create this concept art for a fantasy novel
Generate that illustration about ancient myths
Create an animation showing a volcanic eruption
Generate a portrait depicting a medieval knight
Draw me a dragon on fire
Type your prompt below!
As long as the first parts of it are highlighted in multiple colors, like the examples above, the script will recognize your prompt and generate an image.
Type here...
';
my $regex = qr/^(generate|create|draw|make) (me|an?|the|this|that)? .* (at|in|on|of|for|about|showing|depicting|illustrating)/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}