package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`зак[А-Яа-я]+`)
var str = `Шурыгина может закрыть тебя на 8 лет`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}