$re = '/зак[А-Яа-я]+/';
$str = 'Шурыгина может закрыть тебя на 8 лет';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);