using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=t\(').+?(?='\))|(?<=t\(').+?(?=', {)";
string input = @"case 'cryptocurrencies':
return this.$t('Text 1', { company: this.$global.company, num: this.$global.companyAge });
case 'currencies':
return this.$t(
'Text 2',
{
company: this.$global.company,
num: this.$global.companyAge
}
);";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}