import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=t\\(').+?(?='\\))|(?<=t\\(').+?(?=', \\{)";
final String string = "case 'cryptocurrencies':\n"
+ " return this.$t('Text 1', { company: this.$global.company, num: this.$global.companyAge });\n"
+ " case 'currencies':\n"
+ " return this.$t(\n"
+ " 'Text 2',\n"
+ " {\n"
+ " company: this.$global.company,\n"
+ " num: this.$global.companyAge\n"
+ " }\n"
+ " );";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}