package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^|,)([^\s,]+)(?:\s+[^\s,]+)*`)
var str = `hi,hello,sky,hi hello there`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}