# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<hora>[0-9]{8})\s(?<mix>\d{3})(?<resp>[I|O])"
test_str = (" 09523744 865O F010@@@@Y1905A46100000002 00000000151100157600STD20001\n"
" 865O 030202040005 1029 003047100000000012602 \n"
" 865O 00000000000000000000000000000000000000000000517712002534\n"
" 865O 4898 ")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.