re = /(?<hora>[0-9]{8})\s(?<mix>\d{3})(?<resp>[I|O])/
str = ' 09523744 865O F010@@@@Y1905A46100000002 00000000151100157600STD20001
865O 030202040005 1029 003047100000000012602
865O 00000000000000000000000000000000000000000000517712002534
865O 4898 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end