#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=,)\d+(?=%)"
Local $sString = "Arthur Albert,74% " & @CRLF & _
"Melissa Hay,72%" & @CRLF & _
"William Jones,85%" & @CRLF & _
"Rachel Lee,68%" & @CRLF & _
"Joshua Planner,75%" & @CRLF & _
"Jennifer Ranger,76%"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")