re = /(x=|y=)\"\s*([-]?[0-9]+)\s*\"/m
str = '<polygon>
<vertex x="-15" y="15"/>
<vertex x="-15" y="-15"/>
</polygon>
<polygon>
<vertex x="15" y="-15"/>
<vertex x="15" y="15"/>
</polygon>
<polygon>
<vertex x="-15" y="-15"/>
<vertex x="15" y="-15"/>
</polygon>'
subst = '\\1"\\2\\*factor"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result