// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(x=|y=)\"\s*([-]?[0-9]+)\s*\""#).unwrap();
let string = "<polygon>
<vertex x=\"-15\" y=\"15\"/>
<vertex x=\"-15\" y=\"-15\"/>
</polygon>
<polygon>
<vertex x=\"15\" y=\"-15\"/>
<vertex x=\"15\" y=\"15\"/>
</polygon>
<polygon>
<vertex x=\"-15\" y=\"-15\"/>
<vertex x=\"15\" y=\"-15\"/>
</polygon>";
let substitution = "\\1\"\\2\\*factor\"";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}