import Foundation
let pattern = #"(x=|y=)\"\s*([-]?[0-9]+)\s*\""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<polygon>
<vertex x="-15" y="15"/>
<vertex x="-15" y="-15"/>
</polygon>
<polygon>
<vertex x="15" y="-15"/>
<vertex x="15" y="15"/>
</polygon>
<polygon>
<vertex x="-15" y="-15"/>
<vertex x="15" y="-15"/>
</polygon>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"\2\*factor""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)