#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*/([^/]+)/?$"
Local $sString = "http://www.xx.com/download/apple-Selection-products/beauty-soap-ICs/" & @CRLF & _
"http://www.XX.com/download/apple-Selection-products/beauty-soap-ICs"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)