import Foundation
let pattern = #".*/([^/]+)/?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://www.xx.com/download/apple-Selection-products/beauty-soap-ICs/
http://www.XX.com/download/apple-Selection-products/beauty-soap-ICs
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)