import Foundation
let pattern = #"(\;?(3[0-9]{14}|[4-5][0-9]{15})=2[0-9](01|02|03|04|05|06|07|08|09|10|11|12)[1-2][0-6]{2}[a-zA-Z0-9 ]{7,13}\??)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
%B4455000000660490^FARNSWORTH/SHANE ^24102010001090100001?
B4455000000660490^FARNSWORTH/SHANE ^24102010001090100001
as4455000000660490=24102010001090100001as
av8r;4455000000660490=24102010001090100001?67ab67
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)