# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<at\s)/\1onclick="clickMention(this.id)" /gm;t' <<< "<at id=\"user-01\">Jonh</at> in group <at id=\"group-02\">Android</at>"