using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<at\s)";
string substitution = @"\1onclick=""clickMention(this.id)"" ";
string input = @"<at id=""user-01"">Jonh</at> in group <at id=""group-02"">Android</at>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}