use strict;
my $str = '<at id="user-01">Jonh</at> in group <at id="group-02">Android</at>';
my $regex = qr/(<at\s)/mp;
my $subst = '\\1onclick="clickMention(this.id)" ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";