re = /(<at\s)/m
str = '<at id="user-01">Jonh</at> in group <at id="group-02">Android</at>'
subst = '\\1onclick="clickMention(this.id)" '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result