import Foundation
let pattern = #"(<at\s)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<at id="user-01">Jonh</at> in group <at id="group-02">Android</at>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1onclick="clickMention(this.id)" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)