const regex = /^([^,]*,){1}jeremy,/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^,]*,){1}jeremy,', '')
const str = `20116,jeremy,chrome.exe,C:\\Program Files (x86)\\Google\\Chrome\\Application\\chrome.exe,19233,chrome.exe,,,,"C:\\Program Files (x86)\\Google\\Chrome\\Application\\chrome.exe" --type=renderer`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}