using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(YY){1,2}([\.\/-])(MM|Mmm)\2(DD)";
string input = @"YY-MM-DD";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}