const regex = /^(?:[1-9]|1[0-2]):[0-5][0-9]\s(?:[aApP](\.?)[mM]\1)?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[1-9]|1[0-2]):[0-5][0-9]\\s(?:[aApP](\\.?)[mM]\\1)?$', '')
const str = `1:23 am`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}